• Du musst dich registrieren, bevor du BeitrĂ€ge verfassen kannst. Klicke auf Jetzt registrieren!, um den Registrierungsprozess zu starten. Registrierte User surfen werbefrei, können Suchen durchfĂŒhren und sehen die volle Darstellung des Forums mit vielen anderen Unterforen!!!

Pi-Ager (Reifeschranksteuerung mittels Raspberry Pi) -Aktuelle Release 4.X.X

FC70BA0F-FB1E-40F7-B047-3668D0AED8AE.jpeg

Ok das mit dem anschlussplan hat sich erledigt, ist glaube ich selbsterklĂ€rend😂
Muss ich die Batterie einbauen oder brauche ich die in diesem fall e nicht?
Lg Martin
 
Habs grade installiert!
ohne grĂ¶ĂŸere Probleme.... im prinzp geht auch das alte setup.txt .....wer es noch hat.
Kompliment an die MACHER!
Viele Fragen/VorschlÀge aufgenommen und sehr schön umgesetzt!
werde jetzt erst mal mit dem externen Sensor und evtl. NTC weiter bauen .

das Display ist auch fĂŒr den 3. Ager (fĂŒr nen Kumpel) bestellt.
Bin da echt mal gespannt wie das mit Touchscreen wird.

Macht weiterhin spaß.....
.
 
So das display funktioniert nun auch, ich musste vom RX der Platine auf TX des Display und von TX der Platine auf RX des Display umhÀngen sonst hat es nicht funktioniert.
Ist es geplant dass man ĂŒber das Display mal mehr schalten kann als das Licht?
Hab nun auch den Sensor Extern angeschlossen und ich muss sagen der ist ein must have
Überhaut mit der Absoluten Luftfeuchtigkeit Berechnung fĂŒr ext und int
.
 
Hi,
aus riesiger Neugier hab ich das Display jetzt mal kurz bei mir ...und nicht erst in den ager vom kumpel eingebaut (da fehlt noch material zum bauen)!
Sieht sehr gut aus!
Das einzige was mich kurz ein bisschen stutzig gemacht hat... war das Logo.
Hab 2x hingucken mĂŒssen um zu sehen das es kein Displayschaden... sondern die Grafik ist.
Man muss sehen was sinnvoll ist

Ihr könnt ja hier VorschlÀge machen / Ideen sammeln, dann kann man schauen was sinnvoll und machbar ist.
Aus meiner Sicht wÀren folgende Punkte Sinnvoll am Display....
-Modus Auswahl
-Einstellungen der Sollwerte
und das non plus ultra wÀre....
wenn mann ne wlan suche starten könnte und das passwort eintippen könnte.
Bei der grĂ¶ĂŸe ginge das dann, logischerweise, nur mit nem Stifft.
Das wÀre aber ein Traum!
 
Lasse meinen derzeit als KĂŒhlschrank laufen 6-10grad.

den ziehts aber in den Frostbereich..
hatte ich letztes Jahr auch mal festgestellt, kann also eigentlich nichts mit dem Release zu tun haben.
wundert mich nur das mitgeschrieben wird, dachte mein sensor hat nen schatten.
Alkoholfreie Sachen sind schon geplatzt

Edit.. der scheint nicht immer mitzubekommen wenn der Kompressor lÀuft..
Siehe zweiter screenshot

ADA2B253-9F1A-44AA-8672-F7D53C75E00E.png


80B42D1A-0D8E-4E28-9EBD-7600104A13C6.png
 
wie hast du das verdahtet? Kann es sein dass du den originalen Thermostat noch "irgendwie" eingebunden hast und der die Probeleme macht?
wie sehen deine "Allgemeinen Einstellungen" aus?
Schau mal bitte ob das Relais des Kompressors angezogen ist wenn das passiert.
Kannst auch einen NTC Sensor zum Vergleich in den Schrank reinhĂ€ngen, dann kannst du das Sensorproblem ausschließen.
 
Ist seltsam..
hab jetzt auch mal neu gestartet und den NTC mit reingehangen.

ich hatte letztes Jahr dryage, Schinken und Salami drin gemacht da hatte ich regelmÀssig danach geschaut, glaube nicht das das originale Thermostat noch mit drinnhÀngt.. das ist schon zwei Jahre her

kommt mir aber seltsam vor das er kĂŒhlt der Ager das aber nicht mitbekommt..
ich hatte sowas aber schon ende letzten Jahres als ich ihn als KĂŒhlschrank laufen hatte, da ist mir auch einiges gefroren, ich hatte nicht rausgefunden was es war.
 
In den Kennlinien sieht das aber echt so aus als wenn der Kompressor noch vom Thermostat gesteuert wird.
Im Status siehst du ja das er vom Pi nicht angesteuert wurde.
Und an der roten kurve siehst du das er von irgendwo aktiv gestartet wurde.
Zumindest erkennt man das ab 4:00 Uhr deutlich!
PrĂŒf echt mal das Thermostat ... ich wĂŒrde auch vermuten das es parallel zum Relais hĂ€ngt.
 
Ja mess ich mal durch, bin eigentlich sicher das der nicht mehr drann ist..
es ist allerdings ein KĂŒhlschrank, altes thermostat steht nur auf 3..
Er ist in den Frostbereich gegangen.. passt auch nicht.
 
Der kompressortrend passt irgendwie ĂŒberhaupt nicht zum temperaturtrend
. Hast du screenshots von den anderen trends? Nicht dass du versehentlich zb. Den kompressor mit der umluft schaltest
.
 
Ich glaube, da ich einen dicken Liebherr habe, kommt das von dem Zyklus Umluft und Abluft, der zusĂ€tzlich zum kĂŒhlen gelaufen ist.
Wenn mein Verdampfer vereist ist und die Umluft anlÀuft wird einiges durcheinander gebracht.
Auch ohne eingeschaltetem Kompressor..
Hab das jetzt mal alles ausgeschaltet, sieht bis jetzt gut aus

 
@Tobi68 Mit einem Stromsensor könntest sehen wann der Kompressor eingeschaltet ist und wenn nicht, das wĂ€re die einzigste richt RĂŒckmeldung.
Im Plot des Kompressors wird nur der GPIO Status angezeigt, bei den Istwerten ist ja klar, dass der nicht mehr angesteuert wird.
Dein Kompressor muss noch von was anderem angesteuert werden.
Schau dir mal alle Plots an vieleicht erkennst du was
 wie @33martin es schon sagte.
Zeig uns alle Plots von dem Zeitpunkt, vielleicht kann man was erkennen.
 
Apropos Stromsensor....Ich möchte den gerne einbauen, hast du eventuell noch infos dazu (Bezugsquelle, Anschlussplan...)

Hier ein paar Sachen zusammengefasst.
- Eine gute Info findest du im Hilfetext.
- Frage, welche Pi-Ager Paltinenversion hast du?
- die Platine fĂŒr den Sensor kann mal mit der normalen Platine mitbestellen, @s.ochs hat noch welche, ich habe auch noch ein paar hier rumliegen. Man muss sie nicht nutzen, man kann die Leitungen auch direkt an den Sensor löten, mit Platine ist es nur etwas sauberer aus meiner Sicht.
- Schaltplan gibt es in Github.
- ich versuche nich eine einfache Skizze zu machen.

z.B.

https://de.farnell.com/lem/ho-6-p-sp33/stromsensor-6a-3-14v-dc-bis-3/dp/2664200

1E47F9FC-6FC7-4A55-9F56-2F1A3CDB49A9.jpeg


3DC49288-2F47-46DF-9EC9-F7274456C110.jpeg


4B8D7DC2-620F-478C-8A82-016E6408089E.jpeg
 
@Tobi68 Mit einem Stromsensor könntest sehen wann der Kompressor eingeschaltet ist und wenn nicht, das wĂ€re die einzigste richt RĂŒckmeldung.
Im Plot des Kompressors wird nur der GPIO Status angezeigt, bei den Istwerten ist ja klar, dass der nicht mehr angesteuert wird.
Dein Kompressor muss noch von was anderem angesteuert werden.
Schau dir mal alle Plots an vieleicht erkennst du was
 wie @33martin es schon sagte.
Zeig uns alle Plots von dem Zeitpunkt, vielleicht kann man was erkennen.
schon wieder zwei Flaschen geplatzt..

ich habe jetzt beide Sensoren unten in den Schrank gehangen..
ich glaube jetzt wird die Sache klarer..

018FA973-7569-404F-B15F-2B1BDBAB5000.png
 
@Tobi68 Mit einem Stromsensor könntest sehen wann der Kompressor eingeschaltet ist und wenn nicht, das wĂ€re die einzigste richt RĂŒckmeldung.
Im Plot des Kompressors wird nur der GPIO Status angezeigt, bei den Istwerten ist ja klar, dass der nicht mehr angesteuert wird.
Dein Kompressor muss noch von was anderem angesteuert werden.
Schau dir mal alle Plots an vieleicht erkennst du was
 wie @33martin es schon sagte.
Zeig uns alle Plots von dem Zeitpunkt, vielleicht kann man was erkennen.
So nachdem ich die Temp FĂŒhler nach unten gelegt habe ist die Sache fĂŒr mich klar.
Wenn ich meinen Dicken voll mit Flaschen mache kĂŒhlt der mir den ganzen Inhalt sportlich runter. Ich kann innerhalb 12 Stunden, 4 Kisten Bier nebst einem Fach mit Sekt Sprudel Wein auf 3-5 Grad runterziehen, ist fĂŒr den Liebherr kein Problem.
Dabei vereisst der Verdampfer aber extrem was dazu fĂŒhrt das im unteren Bereich der KĂŒhli in den Frost Bereich geht, der ganze inhalt hat ja schon 3-4 Grad.
Jetzt lege ich bei nem langen Wochenende 😉 nach, die warme Luft steigt im Schrank nach oben, der Sensor sagt kĂŒhlen..
Und schon wird per Umluft wieder eiskalte Luft unten eingesteuert..
Obwohl dort schon im Frostbereich..

Erkenne ich jetzt mal daran das ĂŒber Stunden Nachts die Temperatur langsam sinkt ohne das die KĂŒhlung lĂ€uft.
eigentlich mĂŒsste sie langsam steigen..
Ich werde in Zukunft beim Einsatz als KĂŒhlschrank, den temperaturfĂŒhler im unteren 1/3 platzieren.
und auch noch mal nach der Umluftsteuerung schauen, die muss öfter laufen.
Jetzt war es so sobald Umluft ohne Kompressor an war, kam die eiskalte Luft vom vereisten Verdampfer ohne das der Kompressor lief..

Habe dieses Jahr leider keine richtige Zeit den Schrank als Reifeschrank zu nutzen.. andere Baustellen..
Das Thema mit dem Stromsensor und email gehe ich nÀchsten Monat mal an, mein Schrank soll ins Gartenhaus umziehen, ich hÀtte schon gern ne Nachricht falls durch irgendwas die Sicherung fliegt und kein Strom am Schrank ist.
 
NAbend zusammen, auch von mir eine kleine RĂŒckmeldung zur neuen Version.
Ich nutze den Pi-Ager ja als Zigarrenhumidor bzw. zur Trocknung und Fermentation von Tabak.
Die ersten BlĂ€tter sind geerntet; umso spannender sind fĂŒr mich natĂŒrlich die Neuerung. Taupunkt - perfekt. Display.... noch besser. (Ich hab kein WLAN am Schuppen)
Da ich Waagen etc. nicht benötige habe ich auch keine Platine sondern drahte alles an den Raspberry3 direkt an. Die Version 3.3.1 mit vorerst einem Sensor lief sofort. Das mit der Adressierung fĂŒr den externen Sensor hab ich noch nicht ganz verstanden.. das kommt spĂ€ter.

Ein Problem habe ich jedoch.
Ich habe das Display wie verlinkt bestellt. Kurz an 5V getestet und das kleine Demoprogramm bewundert, Case gedruckt (Danke dafĂŒr).
Jetzt wollte ich das Display heute mit dem Pi-Ager verdrahten und einrichten.
RX an TX bzw. GPIO14 und TX an RX. Pi an und Display mit Strom versorgt, Button im Admin-Bereich gedrĂŒckt.

Fehlermeldung: HMI irgendwas - Check cables

Einmal TX-RX getauscht - gleicher Fehler, Check cables.

Hat jemand eine Idee dazu?
Muss ich doch eine firmware separat hochladen oder den Displayspeicher löschen?

Aber davon ab: Tolle Arbeit, vielen Dank dass das Projekt hier einfach immer besser wird.

Gruß,
Daniel
 
ZurĂŒck
Oben Unten