• Du musst dich registrieren, bevor du Beiträge verfassen kannst. Klicke auf Jetzt registrieren!, um den Registrierungsprozess zu starten. Registrierte User surfen werbefrei, können Suchen durchführen und sehen die volle Darstellung des Forums!!!

Neues Release: WLANThermo 2.6.X

Bjoern

Grillkaiser
5+ Jahre im GSV
Hallo,
ich würde gerne ein neues Release testen.
Lest euch bitte vorab die Schritte gut durch, und macht am besten ein Backup eurer Software, z.B. per win32diskimager.

Es ist noch eine Vorabversion, mit eventuell eingebauten neuen Fehlern.

Schritte zum Test:

1. Login per PuTTY als User (Default: User: pi, Passwort: raspberry).
2. Update herunterladen:
Code:
wget https://cloud.wlanthermo.com/index.php/s/D7hhuDn8BoSpSI2/download -O WLANThermo_install-2.6.0-beta.run
3. Weboberfläche des WLANThermo öffnen, Browser geöffnet lassen!
4. Updateflag erstellen:
Code:
echo [Webpasswort] > update
sudo mv update /var/www/tmp/update
[Webpasswort] natürlich durch euer eigenes ersetzen, ohne Klammern.
Der Browser sollte jetzt "Das Update wird gerade installiert" anzeigen.
5. Update starten:
Code:
sudo bash ./WLANThermo_install-2.6.0-beta.run
6. Jetzt sollte das Update (auf der Konsole) durchlaufen, das Passwort wird auf das oben eingegebene geändert. Dieses dauert mal wieder ziemlich lange, insbesondere da pigpiod neu kompiliert werden muss.
7. In der Weboberfläche wird ein neues Update angezeigt (Infobutton), falls nicht könnt ihr folgendermaßen das Update aktivieren:
Code:
sudo touch /var/www/tmp/nextionupdate
diese anschließend bitte per Klick auf den Button auf der Infoseite ausführen, das Display sollte jetzt den Upload anzeigen.
8. Nach dem Update das WLANThermo herunterfahren, danach vom Strom trennen und wieder einstecken.

Der o.g. Link bleibt gültig, wenn eine neue Version kommt melde ich mich hier im Thread.
 

callahan

Fleischzerleger
10+ Jahre im GSV
Oh cool :-)
Ihr seid die Größten.
Werde das auch mit einer meiner beiden Minis testen :-)
 

callahan

Fleischzerleger
10+ Jahre im GSV
Und das klappt auch bei der Mini v1?

(By the way . . . gab es hier nicht irgendwo die Möglichkeit, eine fertige v2 zu erwerben? Habe aus Zeitmangel ein bisschen den Überblick verloren....)
 

Arminth

Meister Lampe & WLANThermo Papa
10+ Jahre im GSV
Bei zwei Installationen habe ich den Effekt, dass die Plots nicht gespeichert werden, wenn ein neues Logfile erstellt wird.
V1 und auch V2.
@Bjoern Soll ich das auf Github aufmachen?

Grüßle
Armin
 

callahan

Fleischzerleger
10+ Jahre im GSV
So, hab alles gemacht, wie beschrieben . . .
Display zeigt Version 2.3 an (und ist um 180 Grad gedreht), bleibt aber bei "Temperaturen werden geladen" hängen. Webfrontend ist erreichbar, zeigt aber keine Temperaturen.
 

sammy98

Putenfleischesser
5+ Jahre im GSV
Ohne Sensoren eingesteckt zu haben und mit aktiviertem Maverick Receiver zeigt die app.php Kanal 0 und Kanal 1 ohne Fehler an - Kanal 8 für Maverick ist nicht da. Shutdown über die WebUI bleibt hängen
 

callahan

Fleischzerleger
10+ Jahre im GSV
Kannst du vielleicht mal ins Logfile schauen?

2017-02-05 18:59:02,747 - WLANthermo - CRITICAL - <type 'exceptions.AttributeError'>: 'NoneType' object has no attribute 'sendall'
2017-02-05 18:59:02,592 - WLANthermo - CRITICAL - File "/usr/sbin/wlt_2_comp.py", line 400, in <module>
init_softspi_mcp()
File "/usr/sbin/wlt_2_comp.py", line 182, in init_softspi_mcp
retval = pi.bb_spi_open(CS, MISO, MOSI, SCLK, 250000, 0)
File "/usr/local/lib/python2.7/dist-packages/pigpio.py", line 3201, in bb_spi_open
self.sl, _PI_CMD_BSPIO, CS, 0, 20, extents))
File "/usr/local/lib/python2.7/dist-packages/pigpio.py", line 1000, in _pigpio_command_ext
sl.s.sendall(ext)

2017-02-05 18:59:02,605 - WLANthermo - CRITICAL - <type 'exceptions.AttributeError'>: 'NoneType' object has no attribute 'sendall'
2017-02-05 19:15:54,416 - WLANthermo - CRITICAL - File "/usr/sbin/wlt_2_comp.py", line 400, in <module>
init_softspi_mcp()
File "/usr/sbin/wlt_2_comp.py", line 182, in init_softspi_mcp
retval = pi.bb_spi_open(CS, MISO, MOSI, SCLK, 250000, 0)
File "/usr/local/lib/python2.7/dist-packages/pigpio.py", line 3201, in bb_spi_open
self.sl, _PI_CMD_BSPIO, CS, 0, 20, extents))
File "/usr/local/lib/python2.7/dist-packages/pigpio.py", line 1000, in _pigpio_command_ext
sl.s.sendall(ext)

2017-02-05 19:15:54,423 - WLANthermo - CRITICAL - <type 'exceptions.AttributeError'>: 'NoneType' object has no attribute 'sendall'
 

Ha-Ma

Kurvenglätter
5+ Jahre im GSV
ähnliche Fehler hatte ich auch bei einer Beta 2.6.0 ... war aber auf Basis eines früher installierten System das immer wieder upgedatet wurde...
Das war auch reproduzierbar.
Nachdem ich ein Noob als Basis genommen habe lief alles normal...
 

callahan

Fleischzerleger
10+ Jahre im GSV
Die pigpio installation ist bei dir schief gelaufen. Hatte Armin auch mal :-(
Kannst du es vielleicht manuell nachinstallieren?
http://abyz.co.uk/rpi/pigpio/download.html

Die Installation kann mehrere Minuten hängen. Nicht nervös werden
Hat funktioniert! :thumb2:

Es werden auch beide Maverick-Signale empfangen. Aber kann es sein, daß die Einschaltreihenfolge wichtig ist (zuerst die Mini, DANACH den Maverick)?
Wie bekomme ich nun das Display wieder zurückgedreht?
 
Oben Unten